Обновление базы Управление Торговлей 10.3.5 на 10.3.44

При обновлении древней базы 1С Управление Торговлей 10.3.5.1 (работающей под управлением 1С Предприятия 8.1) до версии 10.3.44 пришлось сконвертировать собственно базу движком 1С 8.2, затем поставить конфигурацию на поддержку (объединением с полностью типовой конфигурацией 10.3.5.1).

Конвертация движком 1С 8.3.10 даёт ошибку

Ошибка СУБД:
Действие может быть выполнено только в исключительном режиме доступа ‘C:\1CBases\33/1Cv8.1CD’
по причине:
Действие может быть выполнено только в исключительном режиме доступа ‘C:\1CBases\33/1Cv8.1CD’

Затем я запустил обновление конфигурации через поддержку (напрямую указав CF-файл 10.3.44). Конфигурация обновилась, в дереве объектов на части объектов появились красные замочки.

Поскольку я не знал, были ли изменения в типовом коде конфигурации, перед применением изменений в базу данных проверил : дважды измененных объектов не было! что есть хороший признак.

База обновилась, выдав всего 1 предупреждение (я даже не посмотрел, какое). Обновление в режиме 1С Предприятие через 39 релизов тоже прошло без сучка и задоринки.

Далее нужно было разбираться с данными.
Во-первых, я заполнил параметры налогового учёта для организации, которая отгружает товар.
Во-вторых, я снял галку «Вести учёт по сериям номенклатуры» (учёт по сериям никогда не вёлся) в форме Константы. Галка поставилась сама в ходе обновления на УТ 10.3.44.
В-третьих, оказалось, что в документах реализации не стоит галка «Отражать в бух.учете» даже в тех документах, где есть счет фактура. И в счетах фактурах не заполнен код вида операции (нужно «01»), «Вид счета фактуры» (нужно «На реализацию»), а также способ их выставления (2 — электронно).

Поэтому я написал такой код для обработки «Универсального подбора и обработки объектов (с диска ИТС)» :

Если НЕ ЗначениеЗаполнено(Объект.ВидСчетаФактуры) Тогда
 Объект.ВидСчетаФактуры =  Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(Объект.КодВидаОперации) Тогда
 Объект.КодВидаОперации = «01»;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(Объект.КодСпособаВыставления) Тогда
 Объект.КодСпособаВыставления = 2;
КонецЕсли;
Объект.Записать(); // запись счета фактуры

Док1с = Объект.ДокументОснование; // документ реализации
Если ЗначениеЗаполнено(Док1с) Тогда
 Док2с = Док1с.ПолучитьОбъект();
 Док2с.ОтражатьВБухгалтерскомУчете = Истина;
 Объект.КодВидаОперации = «01»;
 Объект.КодСпособаВыставления = 2;
 Док2с.Записать();
КонецЕсли; // запись реализации

и с помощью этого кода обработал все проведенные документы «Счет фактура выданный» — чтобы их можно было распечатать.

Далее оказалось, что оперативное проведение документов «по организации» не работает. Я в групповой обработке установил флажок «Отражать в бух.учете» для всех проведенных поступлений товаров. И затем в той же обработке (не закрывая её) перепровёл эти документы.

Всё это обновление было нужно для того, чтобы предоставить актуальные печатные формы счетов фактур. Оказывается, организация много лет работала на древнейшем релизе 1С Управление Торговлей, а форму счета фактуры 2012 ей сделали в виде внешней печатной формы.

Запись опубликована в рубрике Регламенты с метками , . Добавьте в закладки постоянную ссылку.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.